Gdzie sie to ukrywa...?

w dziale Wersje beta, testowe i rozwojowe
Frankosio napisał(a):

Witam, może ktoś spotkał się z tym problemem i potrafi go rozwiązać, otóż...
żadna wersja 9 Opery, jakie do tej pory wgrywałem nie wyświetla mi ramek wbudowanych (chyba tak to się nazywa) pomimo że mam to zanaczone w opcjach.
W wersjach 8 Opery nigdy nie miałem takiego problemu sad
Uruchomiłem obie wersje równocześnie i porównywałem ustawienia - są identyczne, a pomimo to w wersji 9wygląda to tak jak pokazuję na przykładowych screenach.

PRZYKŁAD 1: strona http://frankosio.neostrada.pl
Opera 8.54op8.jpgOpera 9beta2op9.jpg
PRZYKŁAD 2: strona http://radioapma.elzet.biz
Opera 8.54op8-2.jpgOpera 9beta2op9-2.jpg
Jeśli wiecie jak to "naprawić" to byłbym wdzięczny za wskazówki.

adas napisał(a):

To jest chyba jakiś flash. Zobacz czy masz wtyczkę flasha. A jak nie masz to zaistaluj.

Frankosio napisał(a):

Originally posted by adas:

To jest chyba jakiś flash. Zobacz czy masz wtyczkę flasha. A jak nie masz to zaistaluj.


W przykładzie 1 jest flash, ale w przykładzie 2 nie.
Wtyczki mam zainstalowane i nie ma problemu z wyświetlaniem flashek, animacji czy obrazków na stronach.
Problem nadal pozostaje otwarty.......sad

quiris napisał(a):

Originally posted by Frankosio:

PRZYKŁAD 1: strona http://frankosio.neostrada.pl


Mam zainstalowaną betę Flasha 9 http://fileforum.betanews.com/search?search=Macromedia+Flash+Player+for+Windows i zarówno W Operze 9, MSIE 7, jak i Firefoksie wygląda tak samo, tzn. mam szare pole. Wg mnie Opera 9 blokuje dostęp z uwagi na cross-site scripting co jest niedozwolone. W Konsoli błędów mam:

JavaScript - http://www.aqtc.neostrada.pl/player/music.html
Unknown thread
Error:
name: Error
message: Security violation



Originally posted by Frankosio:

PRZYKŁAD 2: strona http://radioapma.elzet.biz


Przykład drugi działa bez problemów.

adas napisał(a):

Originally posted by quiris:

Wg mnie Opera 9 blokuje dostęp z uwagi na cross-site scripting co jest niedozwolone


Pod linuksem wyświetla (ale flash 7).

Frankosio napisał(a):

Originally posted by quiris:

Wg mnie Opera 9 blokuje dostęp z uwagi na cross-site scripting co jest niedozwolone.


Hmm... chyba masz racje, bo innego rozwiązania nie widze. Wszystkie flashki wyświetlają sie bez problemu, jeśli są osadzone na stronie, a w tym przypadku jest to ramka z zawartością innej strony (player we flashu).
Dziwi mnie tylko, że pod wcześniejszymi Operami (v.6, 7, 8) z wyświetlaniem takich gadżetów nie było problemu i dopiero wersje 9 mają z tym problemy.

Przykład drugi działa bez problemów.


Pod oficjalną beta2 (build 8414) nie działa, ale zainstalowałem wersje weekly build 8490 i faktycznie... okienko radia już jest widoczne smile

No i teraz zastanawiam się gdzie tkwi błąd ?
Przecież zarówno przykład 1 jak i 2 jest tak samo "skonstruowany" tzn. osadzona na stronie ramka ma zawartość innej strony. Różnica tkwi tylko w wyświetlanych elementach grafiki.... hmm... dziwne:worried:

quiris napisał(a):

Originally posted by Frankosio:

Przecież zarówno przykład 1 jak i 2 jest tak samo "skonstruowany" tzn. osadzona na stronie ramka ma zawartość innej strony. Różnica tkwi tylko w wyświetlanych elementach grafiki.... hmm... dziwne


Możliwa jest jeszcze jedna przyczyna. Plik SWF w pierwszym przypadku może być uszkodzony, ponieważ Firefox raz zakomunikował mi jakieś problemy z tym plikiem.

Frankosio napisał(a):

Originally posted by quiris:

Możliwa jest jeszcze jedna przyczyna. Plik SWF w pierwszym przypadku może być uszkodzony, ponieważ Firefox raz zakomunikował mi jakieś problemy z tym plikiem.


Uszkodzony nie jest na pewno. Zrzut screenów przykładu 1 robiłem równocześnie na Operze 8 i 9, a jak pewnie zauważyłeś pod ósemką wszystko wyświetla się prawidłowo.

quiris napisał(a):

Originally posted by Frankosio:

Uszkodzony nie jest na pewno. Zrzut screenów przykładu 1 robiłem równocześnie na Operze 8 i 9, a jak pewnie zauważyłeś pod ósemką wszystko wyświetla się prawidłowo.

To, ze wyświetla się w niektórych przypadkach, nie znaczy, że wszystko jest z nim w porządku.