Poszerzony player na YouTube

w dziale Wersje beta, testowe i rozwojowe
Medium napisał(a):

Czy to efekt zmian w witrynie YouTube, czy też konfliktu ostatnich testowych wersji Opery z tymi zmianami, że w YouTube nie mogę zwiększyć (poszerzyć) playera?

Czy ktoś na wersjach RC mógłby to sprawdzić?
Przykład: http://www.youtube.com/watch?v=f4e1BUl7ttg

karolkuich napisał(a):

U mnie działa dobrze.

Wersja
12.15
Kompilacja
1745
Platforma
Linux
System
x86_64, 3.5.0-26-generic

Medium napisał(a):

Dzięki! Magazyn wyczyściłam, ciasteczka wyczyściłam, nawet zmieniłam identyfikację dla witryny...
Co się nagle stało?
Ktoś wie, co ma wpływ na tę funkcję?

lemari napisał(a):

Originally posted by Medium:

Ktoś wie, co ma wpływ na tę funkcję?


A prawoklik na odtwarzaczu i "Ustawienia..." ?

Na XP też śmiga.

Medium napisał(a):

Originally posted by lemari:

A prawoklik na odtwarzaczu i "Ustawienia..." ?

I? Nic tu nie zmieniałam, samo się spuło od wczoraj sad
Na tej samej wtyczce w chrome działa.


lemari napisał(a):

Originally posted by Medium:

Na tej samej wtyczce w chrome działa.


Chrome ma własnego flesza.

Medium napisał(a):

Originally posted by lemari:

Chrome ma własnego flesza.

Jak to własnego? Korzysta z wersji dla przeglądarek alternatywnych, inna wtyczka jest tylko dla IE.


lemari napisał(a):

Originally posted by Medium:

Jak to własnego?


Wbudowany w przeglądarkę.

Nie w sensie własny/inny od googla.

Medium napisał(a):

Originally posted by lemari:

Wbudowany w przeglądarkę.

No coś Ty! U Ciebie Chrome nie korzysta z Flasha?
Może przełączyłeś się na HTML5?

lemari napisał(a):

Originally posted by Medium:

No coś Ty! U Ciebie Chrome nie korzysta z Flasha?


Przeglądarka Chrome zawiera wtyczkę Flash. Nie trzeba pobierać tej wtyczki osobno dla tego programu.
Jeśli używasz tylko Chrome, nie musisz pobierać Flash; ma tę wtyczkę Chrome.

Medium napisał(a):

Originally posted by lemari:

Przeglądarka Chrome zawiera wtyczkę Flash.

Hmm, nie wiedziałam. W każdym razie dziwnym trafem wersja tej wtyczki jest zgodna z tą, którą mam dla alternatywnych przeglądarek w systemie, wcale nie najnowsza.

A próbowałeś w ogóle wyrzucić wszelki Flash z systemu i sprawdzić, jak Chrome zadziała? Może Chrome umiejętnie korzysta z tej od IE (co u mnie akurat nie ma miejsca, bo dla IE mam inną wersję wtyczki)?


lemari napisał(a):

Originally posted by Medium:

Hmm, nie wiedziałam.


Jest z tym ból na Liniksie, Addobe przestało wspierać ten system. Najnowszy flash ma tylko Chrome.

dodane:

Originally posted by Medium:

A próbowałeś w ogóle wyrzucić wszelki Flash z systemu i sprawdzić, jak Chrome zadziała?


Nie musiałem robić takich eksperymentów :-).

aefyk napisał(a):

Originally posted by Medium:

Przykład: http://www.youtube.com/watch?v=f4e1BUl7ttg



Ciekawy materiał, dzięki. A przy okazji, u mnie na viście działa rozszerzanie. Cos wspomniałas, że nie uzywasz najnowszego flasha. Ja cały czas używam najnowszych i działają dobrze, chociaż czytałem o jakichs ... przesądach p że jest inaczej.

Medium napisał(a):

Originally posted by aefyk:

A przy okazji, u mnie na viście działa rozszerzanie. Cos wspomniałas, że nie uzywasz najnowszego flasha.

U mnie na XP też to działa smile Zepsuło się w najnowszej Operze całkiem świeżo a na Operze 11.64 też jest zepsute, tuż przed spóźnionym przejściem na nowelizację. Działa w Operze... 10.63 - ostatniej stabilnej dziesiątce, na tej samej wtyczce Flasha 11.1 smile

Podejrzenie może paść na jakieś rozszerzenie, bo są one w wersjach 11 i 12 (choć nie brałam świeżo nic nowego), albo na samą Operę. Jutro spróbuję zapuścić na nowo instalatory.

Być może też winne jest jakieś specyficzne ustawienie w configu... Ktoś podpowie, gdzie szukać?

Łukash napisał(a):

Originally posted by Medium:

Ktoś podpowie, gdzie szukać?


Jaka wersja Flasha ? wink

Medium napisał(a):

Originally posted by Medium:

na tej samej wtyczce Flasha 11.1


Originally posted by Łukash:

Jaka wersja Flasha ?


Flash_11.1.png

Łukash napisał(a):

Medium napisał(a):

Łukash, wiem, że mam nieaktualny, ale najnowsza Opera i inne przeglądarki alternatywne radziły sobie z tą wersją. Przyczyna nie we wtyczce, bankowo! Jak się zdenerwuję zrobię reset ustawień, na razie do YT używam Opery 10.

Czekam na kogoś, kto ma pojęcie o skryptach, bo przez skórę czuję, że tu jest pies pogrzebany.


Łukash napisał(a):

Originally posted by Medium:

Przyczyna nie we wtyczce, bankowo! Jak się zdenerwuję zrobię reset ustawień



Zdenerwuj się i zaktualizuj Flasha bigsmile

Medium napisał(a):

Originally posted by Łukash:

Zdenerwuj się i zaktualizuj Flasha

Kiedyś mnie nowszy od używanej wersji zdenerwował, można znaleźć na forum. I póki co pamiętam...

ceglash napisał(a):

U mnie też bez żadnego problemu, mogę okno z filmem na YT powiększać i zmniejszać.

Opera 12.15 RC2
Linux/Ubuntu
wersja Flash: Shockwave Flash 11.2 r202

Medium napisał(a):

Winne jest któreś z rozszerzeń. Wyłączenie wszystkich pomogło. Ustalę i dopiszę, które. To była jakaś aktualizacja, bo wcześniej działało.

Medium napisał(a):

Zawiniło lubiane przeze mnie, uniwersalne dla wielu stron z osadzonym video, rozszerzenie Download Media Bar.

Na stronie dodatku czytam:

Lista zmian
- Fix "crossdomain.xml" popup window


Czyżby należało włączyć w konfigu Allow File XMLHttpRequest?


Problem rozwiązuje konkurencyjne rozszerzenie SaveFrom.net helper, które nie powoduje opisanego konfliktu:
poszerzony player na YouTube.png

gwarser napisał(a):

Originally posted by Medium:

Czyżby należało włączyć w konfigu Allow File XMLHttpRequest?


NIE! Ta funkcja - o ile się orientuję (wywalili tę stronę z helpa?) - służy do pobierania plików z dysku za pomocą javascriptu i protokołu "" = niebezpieczne

Originally posted by Medium:

Na stronie dodatku czytam:
Lista zmian
- Fix "crossdomain.xml" popup window


Ktoś zgłaszał w poprzedniej wersji, że zamiast filmu na YT, pobiera mu się ten plik. Plik ten służy do poinformowania flashplayera z jakich domen może pobierać treści (video)

Medium napisał(a):

Originally posted by gwarser:

Ktoś zgłaszał w poprzedniej wersji, że zamiast filmu na YT, pobiera mu się ten plik.

Nigdy nie miałam takiej przygody.

Originally posted by gwarser:

Plik ten służy do poinformowania flashplayera z jakich domen może pobierać treści (video)

Znalazłam go w cache Opery, ale tylko w wersji 10, której ostatnio używałam dla YouTube. A przecież Opera 10 nie obsługuje rozszerzeń, tam były widżety i Unite.

crossdomain.xml_dysk_C.png

gwarser napisał(a):

Originally posted by Medium:

Nigdy nie miałam takiej przygody.


Widocznie ktoś miał, skoro na stronie rozszerzenia jest info o takim błędzie.

Originally posted by Medium:

Znalazłam go w cache Opery, ale tylko w wersji 10, której ostatnio używałam dla YouTube. A przecież Opera 10 nie obsługuje rozszerzeń, tam były widżety i Unite.


??? tego pliku używa flash a nie rozszerzenia http://youtube.com/crossdomain.xml

Medium napisał(a):

Originally posted by gwarser:

??? tego pliku używa flash a nie rozszerzenia

Czyli w Operze 10 jest jakiś błąd? Nie powinna go ściągać? confused

gwarser napisał(a):

O czym ty do mnie rozmawiasz teraz? Ja napisałem tylko, że nie trzeba włączać "Allow File XMLHttpRequest", ponieważ to nie ma nic wspólnego z naprawionym błędem rozszerzenia 'Fix "crossdomain.xml" popup window'.
Ze strony błędów tego rozszerzenia:

madarexxx says:

when i am trying to download video from youtube, i see not video, but crossdomain.xml!!!!

widać, że był pewnie źle generowany link do video i zamiast niego pobierał się ten "crossdomain.xml".
I tyle.

Medium napisał(a):

Originally posted by gwarser:

O czym ty do mnie rozmawiasz teraz?

Myślałam, że może mi wytłumaczysz, dlaczego te pliki lądują w cache Opery 10, a już późniejszych wersji nie.