problem ze sciaganiem programow

w dziale Opera
niekumaty napisał(a):

zamiast zwyczajowego w takich wypadkach okienka, pojawia sie strona zapisana robaczkami, czy to kwestia ustawien przegladarki? moglby mi ktos podpowiedziec

bmisiekb napisał(a):

powiem jedno PRZYKŁADY wink to będzie wszystkim łątwiej jakos pomóc

a na moje oko - to próbujesz ściągać program, niby plik, a tak naprwede to jest link który cie przenosi na jakś stronę, jeżeli robaczki oznaczają takie prostokąciki (czy tam kwadracik) to prawdopodobnie jakaś chińską/japońską lub inne wschodnie. No i pewnie gdzies na tej stronie jest własciwy link do pliku. W Operze może uda Ci się go znaleść używając z panelu bocznego pola "Odnośniki"
aktywujesz je klikając Shift+F12 -> zakładka Panele i tam zaznacz odnośniki

Ziggy X napisał(a):

nie bmisiekb, nie o to chodzi. Też się z tym spotykam i to tylko w operze. To coś chyba z błednym mimetype, nie znam się, niech ktoś się wypowie jak wie wink tylko szkoda że w innych przeglądarkach mimo tego działa wszystko ok a w O nie sad

bmisiekb napisał(a):

Czyli mam rozumieć że plik zamiast sie ściągać tak jakby sie otwiera?

No to nie mam pojęcia co z tym zrobić wink - za cienki w uszach na to jestem wink

Swoją drogą już od dawien dawna nie miałem takiego przypadku. Ale kiedyś chyba pomagało ręczne wklejenie adresu pliku do menadżera, albo PPM i "zapisz element docelowy jako".
W sumie to jedyne co mi teraz do głowy przychodzi. W każdym razie jakoś znajdowałem na to sposoby, chyba że ściągałem przez inna przeglądarkę.

Tak myśląc na bieżąco - może to jest jakieś rozszerzenie, że opera myśli, że je da rade otworzyć i próbuje to zrobić?

Ziggy X - piszesz "mimetype" niestety mam za mało czasu (a siedzę na forum) aby zgłębić choć trochę html, php itp... wink Nauka niestety zmusza do wyrzeczeń ;P

Ziggy X napisał(a):

Originally posted by bmisiekb:

albo PPM i "zapisz element docelowy jako"


tak, to jest rozwiązanie jakie mi ktoś kiedyś podsunął, ale czasem mnie rozbraja to że w innych przeglądarkach to działa bez problemu a tu musi coś nie grać i trzeba to obchodzić..

niekumaty napisał(a):

dzieki za pomoc, chodzi o np KithenDraw z www.dobre programy (ale o ile sie nie myle to z kazdym tak mam), w innych przegladarkach problem nie wystepuje, no ale nie o to przeciez chodzi by do roznych celow uzywac innej przegladarki, poza tym wiem ze mozna ten program w normalny sposob sciagnac przez Opere, po kliknieciu na link cos sie tam laduje o czym swiadczy "licznik" w okienku z adresem strony, ale strona jako taka nie jest zapisana chinskim, ani nawet arabskim pismem, tylko jak pisalem, "elektronicznym"

bmisiekb napisał(a):

No nie wiem. Jak chodzi o KitchenDraw z dobreprogramy to u mnie wszystko jest jak najbardziej ok
wchodze na: http://www.dobreprogramy.pl/index.php?dz=22&id=1602&t=119 i odrazu zaczyna ściągać, a okienko do zapisywania wyskakuje.

niekumaty napisał(a):

bmisiek, a ja bede upieral sie ze akurat u mnie jak najbardziej nie jest ok. inaczej bym Wam glowy tym nie zawracal

Andrzej22 napisał(a):

U mnie KitchenDraw też ściąga się aż miło. Są problemy z otwieraniem pps-ów. Ale to historia znana i stara.

niekumaty napisał(a):

cos podobnego

Zajec napisał(a):

Każdy plik pobierany przez przeglądarke jest wysyłany z serwera razem z nagłówkami. To właśnie na podstawie nagłówków przeglądarka powinna decydować, co zrobić z danym plikiem. Ponieważ niektóre serwery mają słabych administratorów i są źle skonfigurowane zdarza się, że np. plik exe wysyłają z nagłówkiem informującym przeglądarkę, że jest to plik tekstowy. Wtedy przeglądarka tak go traktuje i pokazuje Ci źródło pliki exe - które jest "krzaczkami".

Dziwne, że problem z KitchenDraw występuje tylko u Ciebie. Może korzystasz z jakiegoś Proxy, które coś mąci w nagłówkach?

adas napisał(a):

Preferencje → zaawansowane → pobieranie → zobacz czy tam typ plików exe ma być pobierany czy otwierany przez Operę. Wpisujesz exe w tamtą wyszukiwarkę i potem klikasz 2 razy i zaznaczasz pokaż okno pobierania.

p.s. U mnie też się pobiera.

I czy masz najnowszą Operę 9.10?

niekumaty napisał(a):

mam nowa opere ale nie mam zadnego exe...wpisuje exe i gdzie mam kliknac? (laptop)

Zajec napisał(a):

Wpisz "exe" i odptaszkuj opcję obok pola do wyszukiwania.

niekumaty napisał(a):

ok, odptaszkowuje i pojawiaja mi sie dwie pozycje <application/x-cos tam cos tam...ale co dalej, bo kiedy zatwierdzam ok, problem pozostaje ten sam a gdy znow zagladam w te preferencje wszystko jest spowrotem jak bylo

Zajec napisał(a):

Originally posted by niekumaty:

ok, odptaszkowuje i pojawiaja mi sie dwie pozycje <application/x-cos tam cos tam...ale co dalej



Originally posted by adas:

potem klikasz 2 razy i zaznaczasz pokaż okno pobierania.

niekumaty napisał(a):

ok, w obu przypadkach mam ustawione <otwoz za pomoca Opery> ale to nie skutkuje, jak bylo tak jest

Zajec napisał(a):

Żarty sobie robisz?

Originally posted by adas:

potem klikasz 2 razy i zaznaczasz pokaż okno pobierania.

niekumaty napisał(a):

yes! yes! yes! juz wszystko ok smile))) (sory, ale utkwila mi w pamieci czesc ktoregos postu i tym sie sugerowalem, prosze o wybaczenie) SERDECZNE DZIEKI smile)))

Andrzej22 napisał(a):

Najbardziej zastanawiające jest to, dlaczego u Ciebie ten problem jednostkowo wystąpił ? U 99,9% użytkowników to nie występuje. Ale teraz, gdy już możesz ściągać nie wiem czy warto łamać sobie nad tym głowę ?

niekumaty napisał(a):

ja tez nie wiem (moglbym poprzestawiac cos przypadkiem ale od tamtej zakladki nawet nie zagladalem) i glowy tym sobie zawracal nie bede, a tym bardziej Wam

adas napisał(a):

Originally posted by niekumaty:

ja tez nie wiem (moglbym poprzestawiac cos przypadkiem ale od tamtej zakladki nawet nie zagladalem) i glowy tym sobie zawracal nie bede, a tym bardziej Wam


Może przy ściąganiu jakiegoś pliku kazałeś mu się otworzyć przez Operę... Ale to taki strzał...

niekumaty napisał(a):

przypominam sobie ze to moglo miec miejsce