Opera 9.5 i wreszcie zacznie działać?

w dziale Opera dla systemów Linux, Mac OS, FreeBSD oraz Solaris
inzaghi89 napisał(a):

Swojego czasu na jogu Adasia wyczytałem, że Opera 9.5 ma wreszcie zacząć współpracować z wtyczkami linuksowymi, jak to już od dawna robi Firefox. Jak to się ima do rzeczywistości, faktycznie poczyniono jakieś kroki w celu udoskonalenia współpracy z systemami uniksowymi? Czy wreszcie zacznie działać Totem i flash poprawnie? Nie wymagam działania Shockwave, ponieważ nawet adobe nie udostępniło go dla Linuksa, ale czy w końcu Opera zacznie działać tak dobrze na Uniksach jak FF?

Prosiłbym o jakieś rozwinięcie tego tematu i dyskusje na ten temat, oraz podzielenie się informacjami wink.

M-Z napisał(a):

Originally posted by inzaghi89:

Swojego czasu na jogu Adasia wyczytałem, że Opera 9.5 ma wreszcie zacząć współpracować z wtyczkami linuksowymi, jak to już od dawna robi Firefox.


Well, Firefox współpracuje jak może, ale Flash pod Linuksem w ogóle jest zrypany.

Jak to się ima do rzeczywistości, faktycznie poczyniono jakieś kroki w celu udoskonalenia współpracy z systemami uniksowymi?


Kroki na pewno podjęto - były jakieś weekly buildy, w których Flash miał działać jeszcze gorzej w ramach tego, że pracują mocno nad nim. wink

Czy wreszcie zacznie działać Totem


Uchowaj Boże... wink

i flash poprawnie?


Podobno, ale na razie nie działa.

Nie wymagam działania Shockwave, ponieważ nawet adobe nie udostępniło go dla Linuksa, ale czy w końcu Opera zacznie działać tak dobrze na Uniksach jak FF?


Jak FF to może, jak Opera for Windows to nie. wink

Zaufany napisał(a):

To raczej wtyczki dla systemów linuksowych nie chcą współpracować z Operą. Ale mniejsza z tym. Build 1772 pod względem działania wtyczek jest znacznie lepszy od ostatniej, stabilnej Opery. Stosuję go do codziennej pracy, ale nie jest jeszcze zainstalowany.

http://snapshot.opera.com/unix/snapshot-1772/

inzaghi89 napisał(a):

Originally posted by M-Z:

Well, Firefox współpracuje jak może, ale Flash pod Linuksem w ogóle jest zrypany.


Tak, ale nie zmienia to faktu, że pozostają jeszcze wtyczki od takich protokołów jak mms (alternatywa WMP windowsowego itd.), z którymi O sobie nie radzi niestety...

Originally posted by Big_Z:

To raczej wtyczki dla systemów linuksowych nie chcą współpracować z Operą.


W którymś z tematów właśnie wyczytałem czyiś post na ten temat i zgadzam się z tym, jednak... czy to jest powód, by zaprzestać prac i pozwolić Operze odejść w zapomnienie na Uniksach? - NIE! Brakuje mi na Linuksie Opery... bardzo, ale wolę jednak funkcjonalnego FF niż niefunkcjonalną Operę...

M-Z napisał(a):

Originally posted by inzaghi89:

Tak, ale nie zmienia to faktu, że pozostają jeszcze wtyczki od takich protokołów jak mms (alternatywa WMP windowsowego itd.), z którymi O sobie nie radzi niestety...


Wolałbym plugin Kmplayer'a zamiast totem'a; od biedy zwykły (g)mplayer.

W którymś z tematów właśnie wyczytałem czyiś post na ten temat i zgadzam się z tym, jednak... czy to jest powód, by zaprzestać prac i pozwolić Operze odejść w zapomnienie na Uniksach? - NIE! Brakuje mi na Linuksie Opery... bardzo, ale wolę jednak funkcjonalnego FF niż niefunkcjonalną Operę...


Well, mnie brak Flasha nie zniecheca do używania Opery (prawdę mówiąc Flash jest mi potrzebny jedynie na youtube i stronach pokrewnych). Jasne że jest to utrudnienie, bo trzeba się przełączyć do innego programu, ale Opera ma tyle innych zalet, że (przynajmniej dla mnie) jest niezastępowalna przez żadną inną przeglądarkę.

Zaufany napisał(a):

Opera dla Linuksa się rozwija, dodają do niej obsługę pluginów dla Gecko dla Liuksa, są postępy. Poza tym są strony do ściągania filmów z YouTube'a i podobnych do postaci samodzielnych plików, które mplayer odtwarza bez wiekszych problemów.

Darck napisał(a):

w tej wersji ktora tu: http://snapshot.opera.com/unix/snapshot-1772/ podales dzialaja pluginy z gtk? Bo pod 9.26, pluginy kompilowane bez gtk nie maja menu. Troche glupio jest wtedy gdy chce sie pelny ekran - trzeba zoomowac okno az film bedzie na pelnym ekranie. Jeśli tak, to rozumiem, że moge korzystać z pluginów mplayera dla firefoxa?

"Stosuję go do codziennej pracy, ale nie jest jeszcze zainstalowany."
co znaczy, że nie jest jeszcze zainstalowany?

Rozumiem, że nie jest to jakaś bardzo zbugowana wersja i warto zamienić 9.26 na tą? Może którąś nowszą, czy nie wiadomo, czy w nowej nie dodadzą nowych bugów? I czy to nie działa gorzej niż 9.26 z flashem?

Czy jest jakas planowana data wydania 9.5 stable?

Zaufany napisał(a):

Nie jest zaintsalowana, a jedynie rozpakowana do katalogu domowego, nie kopiowałem jej do katalogu globalnego. W katalogu globalnym jest stabilna Opera.

Jak potrzebny jest Flash, masz Linuksa AMD64 albo coś, niektóre tygodniówki mogą być lepsze od wersji stabilnej.

Wydanie 9.5 jest planowane wtedy, kiedy:
1. Kod będzie gotowy, czyli stabilny i zawierający dostatecznie dużo usprawnień.
2. Wpływ zmian w silniku na działanie stron internetowych będzie znany, oraz pozytywny albo akceptowalny.
3. Marketingowcy nie będą mieli potrzeby jej nazwać inaczej.

Darck napisał(a):

ale nie odpisales na najważniejsze, bo pierwsze pytanie smile dziala mplayer z gtk, czy nie? Bo inaczej nie widze sensu instalowac.

Zaufany napisał(a):

Daj namiary na jakieś materiały, do których jest potrzebny mplayer, to sprawdzę.

Darck napisał(a):

http://streamick.com , http://itvp.pl

choć tak właśnie powinno, bo w changelog pisza:

Added preliminary support for Flash 9 Beta 2, mplayerplug-in, and other GTK-based plugins by implementing the GTK main loop

Zaufany napisał(a):

Nie udało mi się odtworzyć. Pod Firefoksem itvp też jakoś nienajlepiej mi działa... Może to wina AMD 64?

inzaghi89 napisał(a):

Ok panowie, dobre nowinki mam.

Opera 9.5 - parę dni temu pozbyłem się Totema na rzecz mPlayer'a - filmy wyświetlane na stronach www działają równie dobrze, jak w FF, co oznacza tylko jedno - welcome Opera, bye bye Firefox.

Oficjalnie jeszcze jednak nie podjąłem decyzji, ponieważ:
Opera jest na QT, a korzystam ze środowiska Gnome i mam kilka wątpliwości. Czy Opera w tym środowisku poradzi sobie równie dobrze, co FF? I czy mniej pamięci zżera od ff? Ogólnie można prosić o jakieś porównanie? Używam FF 2.0.0.12 i Operę 9.5, ale jeśli tylko mplayer ruszy mi na 9.26 to na nią się przesiądę (edit: no i działa na 9.26).

Zaufany napisał(a):

To Firefox jest na Gnome? Chyba ma tylko pewne elementy tego środowiska, Opera, nota bene, też się kilku (opcjonalnych) dorobi w wersji 9.5. Poza tym Opera pod KDE też wygląda na obcą aplikację.

inzaghi89 napisał(a):

Swoje opinie (zapewne błędne, lub źle odebrałeś mój post) opieram na info z repozytoriów:

Przeglądarka WWW Firefox
lightweight web browser based on Mozilla
Firefox is a redesign of the Mozilla browser component, similar to Galeon, K-Meleon and Camino, but written using the XUL user interface language and designed to be lightweight and cross-platform.
This browser was previously known as Firebird and Phoenix.

Canonical Ltd. udziela wsparcia technicznego i aktualizacje bezpieczeństwa dla Przeglądarka WWW Firefox
Przeglądarka WWW Firefox świetnie integruje się z pulpitem Ubuntu



Opera
The Opera Web Browser
Welcome to the Opera Web browser. It is smaller, faster, customizable, powerful, yet user-friendly. Opera eliminates sluggish performance, HTML standard violations, desktop domination, and instability. This robust Web browser lets you navigate the Web at incredible speed and offers you the best Internet experience. The binaries were built on Debian using gcc-4.0.0.

Canonical Ltd. udziela wsparcia technicznego i aktualizacje bezpieczeństwa dla Opera
Używanie, modyfikowanie i rozpowszechnianie Opera jest ograniczone przez prawo autorskie lub inne w niektórych krajach.
Opera świetnie integruje się z pulpitem Kubuntu



Co oznacza, że FF lepiej radzi sobie w środowisku Gnome od Opery, która jest przeznaczona na KDE (wg. tych info).

Również mam nadzieję, że Opera dorobi się wersji na poszczególne środowiska ^^, ale nim to nadejdzie... huh

Zaufany napisał(a):

Jeśli chodzi o KDE, Opera i Firefox tak samo nie nadają się do tych środowisk. W przypadku Gnome może być inaczej, ale ja nie używam tego środowiska, więc się nie będę wypowiadał.