[Opera + GNOME + Qt] Arial i Helvetica

w dziale Opera dla systemów Linux, Mac OS, FreeBSD oraz Solaris
Wasacz napisał(a):

Witam,

Mam (zresztą nie tylko ja) problem z poprawnym wyświetlaniem czcionki Arial, jeśli występuje w arkuszu stylów obok fontu Helvetica (bez znaczenia, która ma większy priorytet). Qt zamienia Arial (Helveticę?) na jakiś odpowiednik, który wygląda co najmniej okropnie – jest postrzępiony i całkowicie olewa ustawienia antyaliasingu. W Firefoksie wszystko jest w porządku, ale to GTK. W opcjach qt-config są pozycje dotyczące podmiany fontów, ale po jakielkolwiek zmianie dotyczącej czcionki Arial przywracane są ustawienia domyślne (zamiana Arial na Helveticę i odwrotnie). Zapytałem Wujka™, ale nie miał nic do powiedzenia na ten temat. Oczywiście jakimś rozwiązaniem jest zastosowanie UserCSS, ale podmiana czcionki na „właściwy” Arial działa tylko po dodaniu „!important” (dziwne, prawda?).

Przykładowe strony:
http://jogger.pl/ – nagłówki wpisów;
http://flaker.pl/ – praktycznie wszystkie fonty witryny.

Z góry dzięki za wszelką pomoc.

M-Z napisał(a):

Well, może przyjrzyj się plikom w /etc/fonts/ (w szczególności /etc/fonts/local.conf). Tu powinno być możliwe skonfigurowanie "podstawianie" czcionek, np:

  <match target="pattern" name="family">
    <test qual="any" name="family">
      <string>Helvetica</string>
    </test>
    <edit name="family" mode="assign">
      <string>Verdana</string>
    </edit>
  </match> 

Wasacz napisał(a):

Ustawienia systemowe są ok, problem tkwi właśnie w konfiguracji Qt…

M-Z napisał(a):

Originally posted by Wasacz:

Ustawienia systemowe są ok, problem tkwi właśnie w konfiguracji Qt…


Ale ta "substytucja" działa globalnie. Zatem podmiana Helvetiki na Arial, czy coś innego powinna rozwiązać problem postrzępienia...

Ryszard napisał(a):

Tak sobie wymyśliłem, że gdybyś w Operze ustawił dla "Czcionka: bezszeryfowa" coś łatwego do rozpoznania (czyli jakąś NIEbezszeryfową) to zobaczyłbyś czy Opera wie, że masz Helvetica albo Arial czy używa tej, którą ustawiłeś pod sans-serif.

Wasacz napisał(a):

Originally posted by M-Z:

skonfigurowanie "podstawianie" czcionek


Próbowałem, z restartem środowiska – bez efektu.

Originally posted by Ryszard:

czy Opera wie, że masz Helvetica albo Arial


Także sprawdziłem – Opera twierdzi, że mam czcionkę Helvetica oraz Arial, mimo że mam tylko tę drugą.

Jeszcze jakieś pomysły? Strasznie to przeszkadza smile

Wasacz napisał(a):

Rozwiązanie problemu:

Zmienić ustawienie dotyczące czcionek – Enable Core X Fonts z wartości domyślej (włączone) na wyłączone.

Proponuję dodać do FAQ, bo to nie pojedynczy przypadek smile