Polskie litery w odbieranych mailach .. a zasadniczo ich brak

w dziale Opera Mail - poczta, czat, grupy dyskusyjne i kanały informacyjne
Furbo napisał(a):

W mailu z polskimi czcionkami mam zamiast polskich czcionek robaczki. Problem ten zazwyczaj pojawia się w klientach pocztowych (oprócz Outlook'a). Czy jest jakiś sposób na to by odbierać maile z polskimi znakami w Operze? Robaczki zamiast polskich znaków są mocno irytujące :-(
Z góry dziękuję za pomoc.

Furbo napisał(a):

Automatyczne kodowanie nie pomaga :-(

Automatyczne kodowanie miałem nastawione wcześniej i nie pomaga :-(
Czyli są osoby, które nie mają problemów z polska czcionką?

Mayor napisał(a):

mnie czasem polskie czcionki się wykładają ale wtedy pomaga mi button przełączający pomiędzy trzema najczęściej stosowanymi kodowaniami

jak dałem "kopiuj adres odnośnika" to się skopiowało takie coś:
opera:/button/Set%20encoding,%20%22AUTODETECT-ZH%22%20|%20Set%20encoding,%20%22big5%22%20|%20Set%20encoding,%20%22iso-8859-1%22

jak kliknięcie nie zadziała to wejdź na http://nontroppo.org/wiki/CustomButtons#page
naciśnij "/" i wpisz "autodetect" to przeniesie Cie do tego buttona, przeciągnij go sobie gdziekolwiek i uzywaj wink

Miaua napisał(a):

A masz w preferencjach ustawione kodowanie iso-8859-2 ?

adas napisał(a):

Widok -> Kodowanie -> Wybór automatyczny - powinno pomóc.

Jurek napisał(a):

Nie wiem czy dobrze rozumiem, ale Furbo chodziło raczej o to, że post przychodzący do niego w jakimkolwiek egzotycznym formacie powinien być przerobiony do np. iso -8859-2. Sam jestem ciekaw jak to zrobić.
Jurek.

adas napisał(a):

Post nie powinien być do niczego przerabiany tylko powinien mieć w nagłówku zaznaczone w jakim jest kodowaniu i wtedy Opera z ustawieniem na Wybór automatyczny wyświetli list poprawnie.
Dawno nie dostałem listu, który by się źle wyświetlił w Operze.

Jurek napisał(a):

adas napisał(a)
Post nie powinien być do niczego przerabiany tylko powinien mieć w nagłówku zaznaczone w jakim jest kodowaniu i wtedy Opera z ustawieniem na Wybór automatyczny wyświetli list poprawnie.
Dawno nie dostałem listu, który by się źle wyświetlił w Operze.


Zgadzam się. Nie wszyscy jednak (wiedzą, chcą), że w naszej części Europy obowiązuje iso-8859-2.
P.S.
Zastosowałem patent Mayora.
Jurek

MrL napisał(a):

Ja mam problemy z polskimi znakami w mailach od kilku konkretnych osob,
w mailach od tych kilku osob zawsze mam krzaki.

Nauczylem sie juz ignorowac wszystkie zakrzaczone maile, ale to nie jest
chyba najlepszy sposob, jeszcze mnie cos waznego ominie smile

Furbo napisał(a):

Tkanks very much for help
Mayor's solution works !

Mayor napisał(a):

cool party

Miaua napisał(a):

Nigdy nie miałam zadnych problemów z kodowaniem, az do teraz. Dostaje mejle wygladające tak, jak na załączniku;/ Wszedzie mam kodowanie albo iso-costam-2 albo automatyczne a mimo to oglądam te urocze kwadraciki:(

Miaua napisał(a):

Załącznik p

kwadraciki.png

Ryszard napisał(a):

Dostaje mejle wygladające tak, jak na załączniku;/


Kliknij przy takim mailu w "Pokaż pełny nagłówek" i poszukaj Content-Type: Może nie być.

Miaua napisał(a):

Jest coś takiego:
"Content-Type: text; charset=iso-8859-2"

Ryszard napisał(a):

Jest coś takiego:
"Content-Type: text; charset=iso-8859-2"


No coż, aż tak się na sprawie nie znam, ale wydaje mi się że powinno być text/plain; albo coś takiego. To znaczy Ty na to wpływu nie masz.
Chyba Opera nie wie jaki jest typ kodowania.
Spróbuj z głownego menu Widok - Kodowanie znaków przestawić dla tej wiadomości na iso-8859-2.
Daj linka - może komuś będzie się chciało zapisać na ten biuletyn.

Miaua napisał(a):

Żonglowanie kodowaniem nic nie daje:) Dziwne to jest o tyle, ze w Operze 7.02 nie ma z tym najmniejszego problemu. W którejś z Oper 7.5x albo w 7.23 też było dobrze więc tym bardziej nie rozumiem, co mojej odbiło ;(
Biuletyn jest z Chip (wyrejestrowanie się jest bezbolesne, jakby co smile )

Jurek napisał(a):

Też subskrybuję Chip'a i w nagłówku jest tak jak pisał Ryszard
"Content-Type: text/plain; charset="ISO-8859-2".
Literki mam w porządku.
Jurek

Jurek napisał(a):

Aha, Opera 7.53

Miaua napisał(a):

Widać to moja Opera zwariowała bo dalej subskrybuję kwadraciki happy

Dodatkowo: w Widok->Kodowanie mam ustawione Automatyczne ale na stronie http://poczta.gdynia.pl/cgi-bin/openwebmail.pl mam różne dziwne znaczki zamiast polskich liter. Jak zmienie kodowanie na nasze iso-8859-2 to jest ok mimo, ze w kodzie strony kodowanie jest iso-8859-1. Jak zmienie kodowanie na iso-8859-1 to wracaja krzaczki.

Obok mnie siedzi chłopak z laptopem, kodowanie automatyczne działa mu wszędzie bez zarzutu (też ma 7.53, też Win2k) a w kodzie http://poczta.gdynia.pl/cgi-bin/openwebmail.pl ma iso-8859-2.

Co się stało z moją Operą? cry cry Instalowałam ją na świerzo cry

Miaua napisał(a):

Po zmianie kolejności języków w Narzędzia->Preferencje->Języki->Preferowane Języki dla stron WWW tzn umieszczeniu polskiego na pierwszym miejscu...jest ok.

Alarm odwołany;)

Jurek napisał(a):

Originally posted by Miaua
Po zmianie kolejności języków w Narzędzia->Preferencje->Języki->Preferowane Języki dla stron WWW tzn umieszczeniu polskiego na pierwszym miejscu...jest ok.

Alarm odwołany;)


Uff...wink

bazyli napisał(a):

Znów alarm?

właśnie zaprenumerowałe biuletyn chipa i widzę azjatyckie znaczki (patrz załącznik)
W header jest:
Content-Type: 	text; charset=iso-8859-2


Mam na pierwszym miejscu język pl. nPOP i webmail czytają toto poprawnie. Jadę na Operce 7.54

chip.png