[bug] Border (-bottom) w linkach

w dziale Opera
eXtremo napisał(a):

Mam pewien problem z CSSowym border-bottom w linkach na moim blogu. O co chodzi? Otóż, jeśli taki link jest pierwszym wyrazem w nowej lini, to podkreślenie pojawia się także w lini poprzedniej i czasem przykrywa tylko kilka liter, a czasem też i całe wyrazy, które linkiem być nie powinny! Taka część automatiko staje się linkiem, pomimo tego, że nie zmienia koloru na linkowy, ani nie podświetla się tak jak linki - tak zachowuje się jedynie ten border. Jak wspomniałem, zauważyłem to swego czasu na moim blogu i jeśli ktoś ma szczęście, zobaczy to we wpisach Zakazane phpBB, Nietypowa biżuteria i Ładowanie gałęzi drzewka po ścieżce z adresu (wszystkie widoczne na stronie głównej). Jeśli ktoś nie zobaczy (bo, jak mówiłem, potrzebne jest, by link był pierwszy w lini), oto są obrazki z opisami. :>



Próbowałem ten bug odtworzyć poza moim blogiem i udało mi się (Tutaj screenshot). Wynika z tego, że problem występuje, gdy text jest wyjustowany (text-align: justify;) i ma zmienną szerokość (gdy divowi przypisałem na stałe 200px podkreślenia nie było poza linkiem).

Co o tym sądzicie?

eXtremo napisał(a):

Bleh co jest? p Nikt nie raczy skomentować? :> To może niech ktoś to zgłosi jako bug... ja tam w angliku nie mistrz i pewno walnę kupe byków ;D

skolman napisał(a):

potwierdzam, jest tak jak opisal eXtreme_pl
opera 8.01

owiecc napisał(a):

Nie potwierdzam. U mnie renderuje się dobrze. v8.01

Sorki. Miałem jeszcze za wąskie okno. Rzeczywiście pojawia się podkreślenie.

owiecc napisał(a):

Wypełniłem bug report. bug-175073

eXtremo napisał(a):

Aha.. Zauważyłem coś jeszcze. Ten bug odnosi się do wszystkich podkreśleń borderowych niezależnie, czy to link czy nie. Przed chwilą zauważyłem, że podkreślenie kropkowane przechodzi do poprzedniej lini przy znaczniku <acronym>. Więc to jeszcze bardziej rozbudowany bug. p